Systems failing

Incident Report for MPower Promo

Resolved

All systems look stable and operational.
Posted Feb 15, 2021 - 14:18 MST

Monitoring

We believe we have resolved this issue and are monitoring the situation closely. Will provide additional updates once we have them.
Posted Feb 15, 2021 - 12:48 MST

Update

We are continuing to work on a fix for this issue.
Posted Feb 15, 2021 - 12:48 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 15, 2021 - 11:47 MST

Investigating

We are currently investing issues with our database which are causing failures in our application and stores. We hope to have the issues resolved in the next few hours.
Posted Feb 15, 2021 - 11:36 MST
This incident affected: Stores, Application, and API.