Issues checking inventory

Incident Report for MPower Promo

Resolved

We have fixed the issue affecting the ability to check inventory for some suppliers.
Posted Feb 23, 2021 - 16:14 MST

Identified

We have identified an issue with realtime inventory checks and are working on a resolution.
Posted Feb 23, 2021 - 11:28 MST
This incident affected: Stores.