Issues with follow up notes and adding products to orders

Incident Report for MPower Promo

Resolved

Follow up notes and adding products to orders should be working correctly.
Posted Mar 11, 2021 - 14:18 MST

Identified

We have identified an issue preventing users from seeing follow up notes and adding products to orders. We are currently working on a fix.
Posted Mar 11, 2021 - 14:14 MST
This incident affected: Application.